I got this error while in the Apply Model stage of unsupervised classification. The Train Model worked, I entered samples, I gave the model a name, chose a classifier and features to use. That step went successfully.

I have watched two Trimble videos (from the self-paced tutorial and the YouTube supervised video) just for this particular step and it seems I'm doing everything that the two videos say to do for Apply Model step.

Any ideas? Attached is the error, a screen grab of my Train Model and then Apply Model.

 

Error:

 

Train Model:

 

Apply Model:

 

 

2 comments

  • Shannon Syrstad

    OK I tried removing the many indexes I've created and just use the base 10 bands from the image. This got it to work and classify my image. Now I just need to look into which of the indexes were causing issues.

  • Shannon Syrstad

    OK well I got train/apply supervised classification to work on the 10 original bands only.

    Then I decided to go back and refine some indexes, redo my segmentation, and now it doesn't even like a single band from the camera.

    Error is now:

    The feature "insert bands here" could not be evaluated for some objects. Undefined feature are not allowed in training mode. I can't figure what would be different this time around vs last time.

Recent Discussions

Need more help?

Enter Knowledge Base Contact Support