I am struggling to find an automated way to set nodata for my scenes. As far as I can tell there is no way to set it with an algorithm? So what I am currently doing is to use a customized import. That works OK, except that the import automatically chooses the Intersection option and I cannot find a way to set it to Union. Does anyone have a solution? 

3 comments

  • Matthias Staengel

    Hi Adriaan,

    You should be able to set the "no-data" definitions in the "image layers" tab of the customized import. If you choose "for file" and the apply type "and" this should be a union right?

    Being able to change the no-data value seems to be a bit buggy... I will forward this, but in my case I had to change the apply type to "and" first, then change the handling to "for layer" and then back again to "for file", then I was able to change the value. That's probably not the intended workflow ;).

    Is this what you are looking for? There are many options no-data apply type options that you can choose from.

    Cheers,
    Matthias

  • Adriaan van Niekerk

    Hi Matthias! Thanks for the quick reply.

    This is what I am doing at the moment, but when you open the project after the import the Intersection option is selected in the nodata window (I have a screenshot but I am unable to post it here for some reason - Ah, I see you first have to submit it and then edit in order to add an image).

    The problem is that I want to use the nodata setting for one of the layers that I am importing (because not all of the layers have the correct nodata setting). If I manually select the Union option in the project modification window it sorts it out, but I have not been able to do so using customized import. I love the fact that one can delete layers (using "delete layer") from the process tree. It would be fantastic if "add layer" and "modify nodata" algorithms can be added?

    (I have also noticed that the buggy nature of the nodata setting in the customized import. It only works for certain sequences. )

    Bye,
    Adriaan.

  • Matthias Staengel

    Hi Adriaan,

    Can you check if these settings get you to the correct no data settings that you want?! Setting the "no data" handling to "for layers" and then for each layer set the "no data" apply type to OR.

    Cheers,
    Matthias

Recent Discussions

Need more help?

Enter Knowledge Base Contact Support